Здравствуйте, обновился до Z-way v2.0.0-rc20, следующей командой: wget -q -O - razberry.z-wave.me/install/v2.0.0-rc20 | sudo bash

После этого home-automation-ui не видит девайсов (видит только виджеты, что я создавал в прошлой версии), а expert-ui показывает сообщение: Error handling data from server (см. скриншот)

Скажите, как исправить?alt text

На запрос http://ip:8083/ZWaveAPI/Data/0 отвечает 404 Not Found

Последние строки в логе: tail /var/log/z-way-server.log [2014-11-19 18:41:34.186] [I] [core] Loading module AutoOff from modules/AutoOff [2014-11-19 18:41:34.190] [I] [core] Executing script: /*** AutoOff Z-Way Home Automation module ************************************* ... [2014-11-19 18:41:34.192] [I] [core] Loading module NotificationSMSru from modules/NotificationSMSru [2014-11-19 18:41:34.195] [I] [core] Executing script: /*** NotificationSMSru Z-Way HA module ******************************************* ... [2014-11-19 18:41:34.198] [I] [core] Loading module DelayedScene from modules/DelayedScene [2014-11-19 18:41:34.202] [I] [core] Executing script: /*** DelayedScene Z-Way HA module ******************************************* ... [2014-11-19 18:41:34.204] [I] [core] Starting automation... [2014-11-19 18:41:34.311] [I] [core] Starting storage... [2014-11-19 18:41:34.315] [I] [core] ZWay Automation started [2014-11-19 18:41:34.316] [I] [core] Z-Way object is not loaded. Skipping Z-Way Utilities

задан 19 Ноя '14, 18:03

aidsoid's gravatar image

aidsoid
2516
процент согласия: 0%

отредактирован 19 Ноя '14, 20:02


Судя по всему, нет модуля Z-Wave Binding. Или он не включился.

alt text

ссылка

отвечен 19 Ноя '14, 21:04

Nils_Bohr's gravatar image

Nils_Bohr
2.3k110
процент согласия: 23%

Можно поподробней, пожалуйста. Как выяснить есть модуль или нет, включен он или нет? И что нужно сделать чтобы установить этот модуль (если его нет)?

(19 Ноя '14, 21:43) aidsoid aidsoid's gravatar image

Ага, разобрался, добавил модуль Binding через веб-интерфейс и заработало (/dev/ttyAMA0). Раньше это было в файле /opt/z-way-server/config.xml. Вообще, довольно странный модуль, судя из описания (Loads Z-Wave engine) загружает некий z-wave движок, что это значит, для меня, как для пользователя, загадка. Было бы лучше, если бы разработчики писали чуть более развёрнутые описания к модулям.

(19 Ноя '14, 21:58) aidsoid aidsoid's gravatar image

Мы сейчас обновляем документацию. Надеюсь к стабильному релизу версии 2.0 будет что-то подобное. В будущем этот модуль позволит работать сразу с несколькими Z-Wave стиками, а совсем в будущем со стиками других протоколов.

(20 Ноя '14, 11:24) Nils_Bohr Nils_Bohr's gravatar image

Добрый день, а не подскажете, как добраться до меню, где можно добавить этот модуль? У меня те же симптомы после апгрейда с 1.4 до 2.0.0.

(19 Дек '14, 01:13) vvvy vvvy's gravatar image

В интерфейсе Home Automation. Он должен загружаться. Там Раздел Preferences -> Modules -> Peripherials -> Z-Wave Binding порт указывайте ttyAMA0

(19 Дек '14, 11:04) Nils_Bohr Nils_Bohr's gravatar image

Как решать такую проблему в новой версии? Логин в smarthome выдаёт unable to load data и ничего невозможно сделать.

(04 Дек '15, 16:23) azimarev azimarev's gravatar image

А какой у вас браузер? Видел что в Microsoft Edge просто не загружается наш интерфейс.

(07 Дек '15, 11:31) Nils_Bohr Nils_Bohr's gravatar image
showing 5 of 7 show 2 more comments
Ваш ответ
toggle preview

Следить за этим вопросом

По почте:

Авторизовавшись, здесь Вы сможете подписаться на обновления по этому вопросу.

По RSS:

Ответы

Ответы и комментарии

Основы размётки

  • *курсив* или _курсив_
  • **жирный** или __жирный__
  • ссылка:[текст](http://url.com/ "Суть вопроса")
  • картинка?![alt текст](/path/img.jpg "Суть вопроса")
  • нумерованый список: 1. Foo 2. Bar
  • чтобы добавить перенос строки в тексте, сделайте два переноса строки в редакторе
  • базовые теги HTML также поддерживаются

Теги к вопросу:

×253
×158

Задан: 19 Ноя '14, 18:03

Просмотров: 4,784 раз

Отредактирован: 07 Дек '15, 11:31

powered by OSQA