Здравствуйте! Суть проблемы:

iRidium v2.2.3, RazBerry Z-Way 2.0.1 Не работает управление Z-Wave через iRidium. Что делал:

  1. Скачал библиотеку Z-Wave.irdb
  2. Создал проект, подключил библиотеку Z-Wave.irdb, указал IP-адрес raspberry, порт 8083, логин-пароль (от Z-Way).
  3. Создал команду и фидбек с именем ZWayVDev_zway_11-1-37 (нашел в строке адреса нужного мне устройства) - это реле Fibaro FGS.
  4. Создал кнопку триггер, отправка строки «on, off».
  5. Подключил фидбек In Value.
  6. Загрузил проект в тестовое устройство (iPhone 4S, i2control v2.2).
  7. Реле на кнопку не реагирует, состояние не приходит, через эмулятор на самом ПК тоже не работает.

В данной локальной сети успешно работает другой проект на HDL и на Fibaro Home Center. В чем может быть проблема? Спасибо.

задан 09 Авг '15, 16:05

mavrinpn's gravatar image

mavrinpn
66617
процент согласия: 50%


Пока версия драйвера с авторизацией не готова, есть возможность работать с Z-Way без авторизации:
1) Создайте комнаты и поместите в них устройства, которыми хотите управлять
2) Создайте Анонимного пользователя. Настройки (иконка шестеренки в правом верхнем углу) --> Management --> User management --> Add user --> Anonymous User

После сохранения настроек, доступ к устройствам будет возможен без авторизации.

ссылка

отвечен 14 Авг '15, 13:07

aivs's gravatar image

aivs ♦
10.7k7
процент согласия: 26%

отредактирован 14 Авг '15, 13:07

Спасибо, заработало!

(16 Авг '15, 09:41) mavrinpn mavrinpn's gravatar image

Вы все правильно делаете. К сожалению на данный момент драйвер для RaZberry не поддерживает авторизацию, сейчас работаем над новой версией драйвера, до 15 августа должна появиться на сайте irridiummobile.ru

ссылка

отвечен 11 Авг '15, 13:39

aivs's gravatar image

aivs ♦
10.7k7
процент согласия: 26%

Спасибо огромное! Неделю безрезультатно мучаю техподдержку iRidium...

aivs, по непонятным причинам не могу задать этот вопрос в комментариях на geektimes. Задам здесь: Подключил на Z-Way модуль HomeKit - частично работает (устройства Z-Wave), но хочу сделать реле на GPIO (как у вас в статье). Не получается получить обратную связь от реле. Делал вот так:

system('head -n1 /sys/class/gpio/gpio24/value');

и вот так:

system('[[ cat /sys/class/gpio/gpio24/value == "1" ]] && echo "on" || echo "off"');

Не работает. Что можно сделать?

В .syscommands cat, head и if прописаны.

(13 Авг '15, 10:57) mavrinpn mavrinpn's gravatar image
Ваш ответ
toggle preview

Следить за этим вопросом

По почте:

Авторизовавшись, здесь Вы сможете подписаться на обновления по этому вопросу.

По RSS:

Ответы

Ответы и комментарии

Основы размётки

  • *курсив* или _курсив_
  • **жирный** или __жирный__
  • ссылка:[текст](http://url.com/ "Суть вопроса")
  • картинка?![alt текст](/path/img.jpg "Суть вопроса")
  • нумерованый список: 1. Foo 2. Bar
  • чтобы добавить перенос строки в тексте, сделайте два переноса строки в редакторе
  • базовые теги HTML также поддерживаются

Теги к вопросу:

×253
×158

Задан: 09 Авг '15, 16:05

Просмотров: 1,512 раз

Отредактирован: 16 Авг '15, 09:41

powered by OSQA