Имеется комплект Razberry с установленным и запущенным ПО - Z-way-server, устройства добавлены в сеть Z-Way, успешно "видятся" и управляются через веб-интерфейс. Имеется собственное ПО, мониторящее состояние устройств, путем периодических запросов к Z-way server через HTTP/JSON API (запросы вида /ZWaveAPI/data/last_update_time). Иногда при включении "лампочки" (FGS211) программным методом (запрос /ZWaveAPI/Run/devices...) физическое переключение состояния происходит мгновенно, но обратная связь, о состоянии устройства в ответах на запрос приходит с задержкой до 5 секунд. С чем могут быть связаны такие задержки - в сети Z-Wave или в логике обработки ZWay-сервера ??

задан 13 Янв '14, 17:01

VANESS57's gravatar image

VANESS57
113
процент согласия: 0%


Возможно, в ассоциациях у реле имеется выключенное устройство, и реле тратит время на попытку доставить этот пакет до ответа контроллеру.

ссылка

отвечен 13 Янв '14, 20:35

PoltoS's gravatar image

PoltoS ♦♦
5731412
процент согласия: 27%

Ваш ответ
toggle preview

Следить за этим вопросом

По почте:

Авторизовавшись, здесь Вы сможете подписаться на обновления по этому вопросу.

По RSS:

Ответы

Ответы и комментарии

Основы размётки

  • *курсив* или _курсив_
  • **жирный** или __жирный__
  • ссылка:[текст](http://url.com/ "Суть вопроса")
  • картинка?![alt текст](/path/img.jpg "Суть вопроса")
  • нумерованый список: 1. Foo 2. Bar
  • чтобы добавить перенос строки в тексте, сделайте два переноса строки в редакторе
  • базовые теги HTML также поддерживаются

Теги к вопросу:

×253
×18

Задан: 13 Янв '14, 17:01

Просмотров: 2,355 раз

Отредактирован: 13 Янв '14, 20:35

powered by OSQA